7*24小时值班咨询手机:15101073985(微信同号)   
CCIE
当前位置:网站首页>CCIE
思科认证培训教你配置BGP重分布进IGP
发布日期:2019-09-18 11:10:37 发布者:
因为BGP通常拥有庞大的路由表,所以在将BGP路由表重分布进IGP时,很有可能导致IGP协议停止工作或路由器崩溃,所以为了预防此类事件的发生,慢慢的,IOS默认不允许将BGP重分布进IGP,但是并非所有BGP都不能重分布进IGP,为了放宽限制,默认情况下,只可以将从eBGP邻居学习到的路由和本地路由重分布进IGP,也就是说iBGP路由是不能重分布进IGP的,但是可以手工调整允许将iBGP学习到的路由重分布进IGP。

配置BGP重分布进IGP
 
思科认证培训
说明:
上图中路由器R1,R2,R3配有Loopback地址,地址分别为:
R1  Loopback 0  1.1.1.1/32
R2  Loopback 0  2.2.2.2/32
R3  Loopback 0  3.3.3.3/32 
 
所有路由器之间运行OSPF,并将Loopback 0的地址发布到OSPF中,保证全网Loopback 0之间是可以通信的。
 
1.IGP保证全网Loopback 0互通
说明:此步略,请参见之前配置。
 
2.配置BGP
(1)配置R1的BGP
r1(config)#router bgp 1
r1(config-router)#bgp router-id 1.1.1.1
r1(config-router)#neighbor 2.2.2.2 remote-as 1
r1(config-router)#neighbor 2.2.2.2 update-source loopback 0
r1(config-router)#neighbor 3.3.3.3 remote-as 3
r1(config-router)#neighbor 3.3.3.3 update-source loopback 0
r1(config-router)#neighbor 3.3.3.3 ebgp-multihop 
r1(config-router)#network 11.1.1.0 mask 255.255.255.0
说明:R1与R2建立iBGP邻居,与R3建立eBGP邻居。
 
 
(2)配置R2的BGP
r2(config)#router bgp 1
r2(config-router)#bgp router-id 2.2.2.2
r2(config-router)#neighbor 1.1.1.1 remote-as 1
r2(config-router)#neighbor 1.1.1.1 update-source loopback 0
r2(config-router)#network 22.2.2.0 mask 255.255.255.0
说明:R2与R1建立iBGP邻居。
 
(3)配置R3的BGP
r3(config)#router bgp 3
r3(config-router)#bgp router-id 3.3.3.3
r3(config-router)#neighbor 1.1.1.1 remote-as 1
r3(config-router)#neighbor 1.1.1.1 update-source loopback 0
r3(config-router)#neighbor 1.1.1.1 ebgp-multihop 
r3(config-router)#network 33.3.3.0 mask 255.255.255.0
说明:R3与R1建立eBGP邻居。
 
(4)查看R1的BGP路由表
r1#sh ip bgp 
BGP table version is 4, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - 

internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network          Next Hop            Metric LocPrf Weight Path
*> 11.1.1.0/24      0.0.0.0                  0         32768 i
*>i22.2.2.0/24      2.2.2.2                  0    100      0 i
*> 33.3.3.0/24      3.3.3.3                  0             0 3 i
r1#
说明:R1中包含本地路由11.1.1.0/24,iBGP路由22.2.2.0/24,eBGP路由33.3.3.0/24。
 
3.配置EIGRP
(1)在R1上配置EIGRP
r1(config)#router eigrp 100
r1(config-router)#no auto-summary 
r1(config-router)#network 14.1.1.1 0.0.0.0
说明:在R1与R4之间建立EIGRP。
 
(2)在R4上配置EIGRP
r4(config)#router eigrp 100
r4(config-router)#no auto-summary 
r4(config-router)#network 14.1.1.4 0.0.0.0
说明:在R4与R1之间建立EIGRP。
 
 
(3)查看R4的EIGRP邻居
r4#sh ip eig neighbors 
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   14.1.1.1                Se1/0            137 00:00:44 1590  5000  0  2
r4#
说明:R4已经与R1正常建立EIGRP邻居。
 
 
4.配置BGP重分布进EIGRP
(1)在R1上重分布BGP进EIGRP
r1(config)#router eigrp 100
r1(config-router)#redistribute bgp 1 metric 10000 100 255 1 1500
说明:R1将BGP重分布BGP进EIGRP。
 
(2)在R4上查看EIGRP路由
r4#sh ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     33.0.0.0/24 is subnetted, 1 subnets
D EX    33.3.3.0 [170/2195456] via 14.1.1.1, 00:00:49, Serial1/0
     11.0.0.0/24 is subnetted, 1 subnets
D EX    11.1.1.0 [170/2195456] via 14.1.1.1, 00:00:49, Serial1/0
     14.0.0.0/24 is subnetted, 1 subnets
C       14.1.1.0 is directly connected, Serial1/0
r4#
说明:默认情况下,R1只能将本地路由11.0.0.0/24和eBGP路由33.3.3.0/24重分布进IGP。
 
(3)允许将iBGP重分布进IGP
r1(config)#router bgp 1
r1(config-router)#bgp redistribute-internal
说明:配置BGP允许将iBGP重分布进IGP
 
(4)再次查看R4的EIGRP路由
r4#sh ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     33.0.0.0/24 is subnetted, 1 subnets
D EX    33.3.3.0 [170/2195456] via 14.1.1.1, 00:01:15, Serial1/0
     22.0.0.0/24 is subnetted, 1 subnets
D EX    22.2.2.0 [170/2195456] via 14.1.1.1, 00:00:02, Serial1/0
     11.0.0.0/24 is subnetted, 1 subnets
D EX    11.1.1.0 [170/2195456] via 14.1.1.1, 00:01:15, Serial1/0
     14.0.0.0/24 is subnetted, 1 subnets
C       14.1.1.0 is directly connected, Serial1/0
r4#
说明:配置允许将iBGP重分布进IGP后,就表示允许所有BGP路由重分布进IGP,所以R4从EIGRP收到BGP重分布进来的所有路由。

微信